Internet Explorer 8 und Update KB963027 können unter Vista x64 nicht installiert werden – oder doch?

Written on April 18, 2009

Kurz nach dem Release von Internet Explorer 8 habe ich versucht, diesen unter Vista Ultimate x64 zu installieren.

Allerdings schlug die Installation immer mit der Fehlermeldung (ie8_main.log)

Pre-IE update installation failed, hresult=0x80240022

fehl.

Da die Support-Maßnahmen von Kay Giza leider auch nicht halfen, habe ich das Problem erst mal ruhen lassen.

Beim Microsoft Patchday diese Woche war nun KB963027 dabei und auch dieses schlug fehl, allerdings mit dem Errorcode

0x8007371b

Der Grund hierfür ist in KB9471821 beschrieben und das entsprechende Update ist dort auch zum Download verfügbar.

Nach dessen Installation klappt es auch mit KB963027 und Internet Explorer 8.

Danke an meinen MVP-Kollegen Robear Dyer für die Hilfe.